Ticket #10 (reopened Enhancement)

Opened 9 years ago

Last modified 9 years ago

Core service should return XML additionally to JSON

Reported by: jri Owned by: jri
Priority: Minor Milestone:
Component: DeepaMehta Standard Distribution Version:
Keywords: Cc:
Complexity: 5 Area: API
Module: deepamehta-core

Description

Content negotiation.

Change History

comment:1 Changed 9 years ago by jri

  • Milestone set to Release 4.1

comment:2 Changed 9 years ago by jri

  • severity changed from 3 to 5

comment:3 Changed 9 years ago by dgf

  • Complexity set to 1
  • Module set to deepamehta-core

Core service delivers XML, see changeset:c3da00

comment:4 Changed 9 years ago by dgf

branched version doesn't start

# git reflog
c3da002 HEAD@{0}: checkout: moving from master to jaxb
# mvn clean install -P all
# mvn pax:run

throws the following exceptions

SEVERE: Starting plugin "DeepaMehta 4 Webclient" failed:
java.lang.RuntimeException: Registering REST resources of plugin "DeepaMehta 4 Webclient" failed (namespace=/webclient)
Caused by: com.sun.jersey.api.container.ContainerException: No WebApplication provider is present

comment:5 Changed 9 years ago by JuergeN

see #17

comment:6 Changed 9 years ago by jri

  • Status changed from new to closed
  • Complexity changed from 1 to 5
  • Area set to API
  • Resolution set to wontfix
  • Milestone Release 4.1 deleted

Danny says he doesn't neccesarily need the XML feature in order to start his class generator project. He considers embedding the DM core service instead. The XML feature has no priority for the moment.

comment:7 Changed 9 years ago by jri

  • Priority changed from Major to Minor
  • Status changed from closed to reopened
  • Resolution wontfix deleted

Reopened to keep the XML topic in sight.

Next step towards the XML service is the implementation of two JAXB adapter classes for CompositeValue? and Map of AssociationDefinition?.

Note: See TracTickets for help on using tickets.