Ticket #1004 (closed Defect: fixed)

Opened 7 years ago

Last modified 6 years ago

dm4-workspaces: Migration Nr. 9 fails if some Topicmap Mapcontext do not have a WS assignment

Reported by: Malte Owned by: jri
Priority: Major Milestone: Release 4.8.3
Component: DeepaMehta Standard Distribution Version: 4.8.2
Keywords: Cc:
Complexity: 3 Area: Data Model
Module: deepamehta-workspaces

Description

I just came across this issue while i was trying to install the latest snapshot to the famportal case. I guess this must be especially the case for DM databases initialized before assignments were program wise, e.g. by the dm4-webclient (but i cannot think of a dm version number for that).

WARNUNG: ROLLBACK! (plugin "DeepaMehta 4 Workspaces")
Jul 18, 2016 10:59:30 PM de.deepamehta.core.impl.PluginImpl$1 addingService
SCHWERWIEGEND: An error occurred while adding service de.deepamehta.topicmaps.TopicmapsService to plugin "DeepaMehta 4 Workspaces":
java.lang.RuntimeException: Activation of plugin "DeepaMehta 4 Workspaces" failed
	at de.deepamehta.core.impl.PluginImpl.activate(PluginImpl.java:500)
	at de.deepamehta.core.impl.PluginManager.activatePlugin(PluginManager.java:64)
	at de.deepamehta.core.impl.PluginImpl.checkRequirementsForActivation(PluginImpl.java:464)
	at de.deepamehta.core.impl.PluginImpl.addService(PluginImpl.java:422)
	at de.deepamehta.core.impl.PluginImpl.access$000(PluginImpl.java:45)
	at de.deepamehta.core.impl.PluginImpl$1.addingService(PluginImpl.java:366)
	at org.osgi.util.tracker.ServiceTracker$Tracked.customizerAdding(ServiceTracker.java:932)
	at org.osgi.util.tracker.ServiceTracker$Tracked.customizerAdding(ServiceTracker.java:864)
	at org.osgi.util.tracker.AbstractTracked.trackAdding(AbstractTracked.java:256)
	at org.osgi.util.tracker.AbstractTracked.track(AbstractTracked.java:229)
	at org.osgi.util.tracker.ServiceTracker$Tracked.serviceChanged(ServiceTracker.java:894)
	at org.apache.felix.framework.util.EventDispatcher.invokeServiceListenerCallback(EventDispatcher.java:943)
	at org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:794)
	at org.apache.felix.framework.util.EventDispatcher.fireServiceEvent(EventDispatcher.java:544)
	at org.apache.felix.framework.Felix.fireServiceEvent(Felix.java:4445)
	at org.apache.felix.framework.Felix.registerService(Felix.java:3431)
	at org.apache.felix.framework.BundleContextImpl.registerService(BundleContextImpl.java:346)
	at org.apache.felix.framework.BundleContextImpl.registerService(BundleContextImpl.java:320)
	at de.deepamehta.core.impl.PluginImpl.registerProvidedService(PluginImpl.java:709)
	at de.deepamehta.core.impl.PluginImpl.activate(PluginImpl.java:489)
	at de.deepamehta.core.impl.PluginManager.activatePlugin(PluginManager.java:64)
	at de.deepamehta.core.impl.PluginImpl.checkRequirementsForActivation(PluginImpl.java:464)
	at de.deepamehta.core.impl.PluginImpl.handleEvent(PluginImpl.java:924)
	at org.apache.felix.eventadmin.impl.handler.EventHandlerProxy.sendEvent(EventHandlerProxy.java:415)
	at org.apache.felix.eventadmin.impl.tasks.SyncDeliverTasks$1.run(SyncDeliverTasks.java:145)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.RuntimeException: Installing plugin "DeepaMehta 4 Workspaces" in the database failed
	at de.deepamehta.core.impl.PluginImpl.installPluginInDB(PluginImpl.java:535)
	at de.deepamehta.core.impl.PluginImpl.activate(PluginImpl.java:487)
	... 29 more
Caused by: java.lang.RuntimeException: Running migration 9 of plugin "DeepaMehta 4 Workspaces" failed
	at de.deepamehta.core.impl.MigrationManager.runMigration(MigrationManager.java:147)
	at de.deepamehta.core.impl.MigrationManager.runPluginMigration(MigrationManager.java:103)
	at de.deepamehta.core.impl.MigrationManager.runPluginMigrations(MigrationManager.java:70)
	at de.deepamehta.core.impl.PluginImpl.installPluginInDB(PluginImpl.java:525)
	... 30 more
Caused by: java.lang.NullPointerException
	at de.deepamehta.workspaces.migrations.Migration9.deleteWorkspaceAssignment(Migration9.java:56)
	at de.deepamehta.workspaces.migrations.Migration9.run(Migration9.java:40)
	at de.deepamehta.core.impl.MigrationManager.runMigration(MigrationManager.java:140)
	... 33 more

Change History

comment:1 Changed 7 years ago by jri

  • Status changed from new to accepted

comment:2 Changed 7 years ago by Jörg Richter <jri@…>

In 25052d1a550e6f231a7f9aef02f0c8927b1e51e6/deepamehta:

Fix Workspaces migration 9 (#1009).

Thanks to Malte for reporting!

See #1004.

comment:3 Changed 6 years ago by jri

  • Status changed from accepted to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.