Ticket #1012 (closed Defect: worksforme)

Opened 5 years ago

Last modified 5 years ago

uploaded images not displayed dm4-images 0.9.10 and DM 4.8.3

Reported by: Malte Owned by: Malte
Priority: Major Milestone:
Component: 3rd Party Plugins Version: 4.8.3
Keywords: Cc: jri, JuergeN
Complexity: 3 Area:
Module:

Description

Due to a wrong path value returned by the dm4-images plugin images uploaded are not displayed properly in the dm4-webclient.

To reproduce turning per-workspace-filerepos=off should be enough.

Change History

comment:1 follow-ups: ↓ 3 ↓ 4 Changed 5 years ago by Malte

When i upload an image the filerepo path part returned by the dm4-images plugin is:

/filerepo/%2Fimages%2Fba-mitte-senatsverwaltung-stad-und-umwelt.png

comment:2 Changed 5 years ago by jri

Keep in mind that dm4-images also involves the dm4.host.url setting when constructing the image URL.

In a DM default installation dm4.host.url is set to http://localhost:8080/
Note the slash at end, it is expected by your dm4-images 0.9.10 code.
See your getRepoUri() method in ImagePlugin.java.

See also #995 and #1007.

comment:3 in reply to: ↑ 1 Changed 5 years ago by jri

Replying to Malte:

When i upload an image the filerepo path part returned by the dm4-images plugin is:

/filerepo/%2Fimages%2Fba-mitte-senatsverwaltung-stad-und-umwelt.png

When I do a upload (per-workspace-repos are off) the URL constructed by dm4-images looks good:

http://localhost:8080/filerepo/%2Fimages%2Fdeepamehta-logo-tiny.png

Note that my dm4.host.url is set to http://localhost:8080/

Last edited 5 years ago by jri (previous) (diff)

comment:4 in reply to: ↑ 1 Changed 5 years ago by jri

However, I can't fully understand what you describe.

Replying to Malte:

When i upload an image the filerepo path part returned by the dm4-images plugin is:

/filerepo/%2Fimages%2Fba-mitte-senatsverwaltung-stad-und-umwelt.png

If that's the path returned by dm-images dm4.host.url is apparently set to / in your installation, that is protocol/host/port missing.
This however is a perfect absolute path, so, when protocol/host/port is the same as you're currently surfing everything should be fine.

I just tried it: set dm4.host.url to /. The path looks like yours then. For me it works properly. The image is displayed.

So, I understand what the actual problem is at your side. The path at least seems not to be the problem. So, what do you think is wrong with your path?

Version 0, edited 5 years ago by jri (next)

comment:5 Changed 5 years ago by Malte

Sorry, i truncated it for my example as host/port was correct so definitely not the issue.

Thanks for your help but i just started to think that this might not actually be an issue with the dm4-images plugin but - if that is a perfectly valid path, as you say - this might be an issue of a missing AllowEncodedSlashes NoDecode directive in the apache configuration of that particular instance. That must be it.

See also:
https://trac.deepamehta.de/wiki/UbuntuConfiguringApache2ServerSSLProxy

comment:6 Changed 5 years ago by jri

OK.
And don't forget the nocanon:

ProxyPass http://localhost:8080/ nocanon

comment:7 Changed 5 years ago by jri

  • Status changed from new to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.