Ticket #102 (closed Defect: worksforme)

Opened 9 years ago

Last modified 9 years ago

issue during creation and rendering of person, institution, web resource-topics in the webclient

Reported by: Malte Owned by: jri
Priority: Major Milestone:
Component: DeepaMehta Standard Distribution Version: 4.0.3
Keywords: Cc:
Complexity: 1 Area: GUI
Module: deepamehta-webclient

Description

when creating a "Institution"-topic, the following message appears ~10 times (and probably the number of times this message appears is related to the number of a specific field in the type-definition)

get_view_config_default: data type "undefined" has no default field renderer class

the same happens when i select an existing "institution"-topic on the canvas.

when creating a "Person", a "File Browser" and a "Web resource"-topic the same error message appears. with a "Note"-topic there is no such error message.

Change History

comment:1 Changed 9 years ago by jri

I can't reproduce this error.
Please use the latest sources from master or the binary distro.
Also, try resetting your DB.

comment:2 Changed 9 years ago by jri

... and ensure the DM server is running

Does your problem persist?

comment:3 Changed 9 years ago by Malte

i already used the latest snapshot 4.0.4-20110924.zip and the error occured with a fresh install using the webclient in firefox 4.0. just did it again and i also tried shift+reload in the browser to make sure all scripts are up-to-date, same result.

crazy thing is, in my chromium everything runs fine, not a single warning from the javascript console. this seems to be related to the older (and deprecated) firefox browser i have installed.

comment:4 Changed 9 years ago by Malte

  • Milestone Release 4.1 deleted

comment:5 Changed 9 years ago by jri

  • Status changed from new to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.