Ticket #110 (closed Defect: wontfix)

Opened 9 years ago

Last modified 8 years ago

Warning message when starting deepamehta on Ubunut 10.04 LTS

Reported by: JuergeN Owned by:
Priority: Major Milestone:
Component: DeepaMehta Standard Distribution Version: 4.0.4
Keywords: Cc: dgf
Complexity: 3 Area: Runtime
Module:

Description

I do not think this is of important relevance, but when I start DM on my Ubuntu 10.04 with these versions:

computer:~$ mvn --version
Apache Maven 2.2.1 (rdebian-1)
Java version: 1.6.0_20
Java home: /usr/lib/jvm/java-6-openjdk/jre
Default locale: de_DE, platform encoding: UTF-8
OS name: "linux" version: "2.6.32-33-386" arch: "i386" Family: "unix"


I get an error message:

computer:~/deepamehta$ mvn pax:run
[INFO] Scanning for projects...
[WARNING] POM for 'biz.aQute:bndlib:pom:1.43.0:runtime' is invalid.
Its dependencies (if any) will NOT be available to the current build.

Change History

comment:1 Changed 9 years ago by jri

  • Cc dgf added

I get the same error when running in Maven 2.2.1

Running Maven in debug mode (--debug) brings up:

[DEBUG] Reason: Not a v4.0.0 POM. for project biz.aQute:bndlib at /home/you/.m2/repository/biz/aQute/bndlib/1.43.0/bndlib-1.43.0.pom

There seems something wrong with the POM file's format of the bndlib component, but I can't tell what. At the first sight it looks OK.

Anyway, bndlib is not involved when running DM, just when building DM (its a dependency of the Maven Bundle plugin).

Even building DM with Maven 2.2.1 works OK, despite that WARNING.

When running/building with Maven 3 the WARNING disappears.

Probably dgf can provide the details about that WARNING's origin.

Last edited 9 years ago by jri (previous) (diff)

comment:2 Changed 9 years ago by jri

Should we close this ticket?
Apparently the warning doesn't hurt, and it vanishes when using Maven 3 instead of Maven 2.

comment:3 Changed 8 years ago by JuergeN

  • Status changed from new to closed
  • Resolution set to wontfix
Note: See TracTickets for help on using tickets.