Ticket #152 (closed Task: fixed)

Opened 11 years ago

Last modified 11 years ago

question: "proxied-file access" no ip range restriction / configuration for unrestricted access

Reported by: Malte Owned by:
Priority: Major Milestone:
Component: DeepaMehta Standard Distribution Version: 4.0.5
Keywords: Cc: JuergenN, dgf, silke
Complexity: 3 Area: Communications
Module: deepamehta-proxy

Description

how to configure a generic ip-range for dm4 files-proxy module so that potentially any ip4
number in the internet is allowed to access files underneath my configured folder?

neither a) "*.*.*.*" nor b) "0.0.0.0/255.255.255.255" seemed to work for me.

a) lead to a

{{{java.lang.RuntimeException?: Checking IP range failed (inetAddress="85.183.32.145", range="*.*.*.*"

at de.deepamehta.core.util.JavaUtils?.isInRange(JavaUtils?.java:164)

..
Caused by: java.lang.RuntimeException?: Parsing inet address "*.*.*.*" failed

at de.deepamehta.core.util.JavaUtils?.inetAddress(JavaUtils?.java:175)
at de.deepamehta.core.util.JavaUtils?.isInRange(JavaUtils?.java:157)
... 44 more

Caused by: java.net.UnknownHostException?: *.*.*.*}}}

and b)

java.lang.RuntimeException: Checking IP range failed (inetAddress="85.183.32.145", range="0.0.0.0/255.255.255.255"
	at de.deepamehta.core.util.JavaUtils.isInRange(JavaUtils.java:164)
..
Caused by: java.lang.NumberFormatException: For input string: "255.255.255.255"
	at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65)

i would be very thankful for any help on this issue.

thanks in advance

Change History

comment:1 Changed 11 years ago by jri

Use 0.0.0.0/0
The dm4.proxy.net.filter setting is expected in CIDR notation.
http://en.wikipedia.org/wiki/Classless_Inter-Domain_Routing

comment:2 Changed 11 years ago by jri

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.