Ticket #207 (closed Task: duplicate)

Opened 10 years ago

Last modified 9 years ago

instances of self-built topictypes do not display child-topics in pagepanel (view/edit)

Reported by: Malte Owned by: jri
Priority: Major Milestone:
Component: DeepaMehta Standard Distribution Version: 4.0.9
Keywords: Cc:
Complexity: 3 Area:
Module:

Description

the info-renderer does not show any child topics anymore thus the compositon definitions configuration look the same as in standard topictypes, e.g. note.

maybe my settings are just wrong. maybe we can investigate this together. the platforms console does not render any warning/error message when topic is fetched.

as one can see on a selected "themenkomplex" view there is also no "edit" button / no lower toolbar in the page panel

Attachments

PagePanel-CustomTopicType.png (84.0 KB) - added by Malte 10 years ago.
instance info in page panel
CustomTopicTypeSettings1.png (96.1 KB) - added by Malte 10 years ago.
CustomTopicType2Setting.png (84.8 KB) - added by Malte 10 years ago.
CustomTopicType3Settings.png (74.1 KB) - added by Malte 10 years ago.

Change History

Changed 10 years ago by Malte

instance info in page panel

Changed 10 years ago by Malte

Changed 10 years ago by Malte

Changed 10 years ago by Malte

comment:1 Changed 10 years ago by jri

Yes, I see your problem.
Your screenshots show everything is OK with your type definition.

The problem is in the *View Configuration* topic of the "Themenkomplex" type.
To fix it
1) Click the View Configuration topic
2) Press Edit
3) Check the "Editable" and "Viewable" checkboxes
4) Press Save. Now everything should be fine again.

I filed a new ticket #208 that addresses the underlying problem.

comment:2 Changed 9 years ago by jri

  • Status changed from new to closed
  • Resolution set to duplicate

The underlying problem is now addressed in #208

Note: See TracTickets for help on using tickets.