Ticket #239 (closed Defect: fixed)

Opened 10 years ago

Last modified 9 years ago

images contain https:// src-links

Reported by: Malte Owned by: rk
Priority: Critical Milestone:
Component: Drupal Website Version: 4.0.9
Keywords: Cc:
Complexity: 3 Area:
Module:

Description

with the result that if you havent yet accepted our certificate, images on the frontpage will not appear unless youve done so. but, no one is asking you, if you really want to see images embedded on our website..

frontpage img src="https://www.deepamehta.de/sites/default/files/swe-book-800.png"

Attachments

SCreenshotImagesHttps.png (67.6 KB) - added by Malte 10 years ago.
relative_path.patch (2.0 KB) - added by rk 10 years ago.
dm1.png (74.4 KB) - added by rk 9 years ago.
Certificat error https://deepamehta.de

Change History

Changed 10 years ago by Malte

comment:1 Changed 10 years ago by rk

The problem is caused by this issue:

https://drupal.org/node/1377840

Changed 10 years ago by rk

comment:3 Changed 10 years ago by rk

  • Owner set to rk
  • Status changed from new to accepted

relative_path.patch should fix the issue. Please check!

comment:4 Changed 10 years ago by rk

  • Status changed from accepted to closed
  • Resolution set to fixed

Closing this. Please reopen if problems accur.

comment:5 Changed 10 years ago by Malte

I just double checked it. Now the images are shown across http/https visits to the website:

src="www.deepamehta.de/sites/default/files/swe-book-800.png"

That seems to do the trick.

Thanks a lot for fixing this, rk!

comment:6 Changed 10 years ago by rk

Changed Flattr-Button to https only, to fix security warning in Chrome/Chromium?.

Changed 9 years ago by rk

Certificat error https://deepamehta.de

comment:7 Changed 9 years ago by rk

We have still one case when we get certificat errors: https://deepametha.de
See screenshot. This happend to me a few times after clearing the cache, but not every time.

I redirect everything to http(s):www.deepamehta.de now. Hopefully this will solve the remaining issues.

Note: See TracTickets for help on using tickets.