Ticket #333 (closed Defect: worksforme)

Opened 8 years ago

Last modified 8 years ago

uncaught type error while panning map-panel

Reported by: Malte Owned by:
Priority: Major Milestone:
Component: DeepaMehta Standard Distribution Version: 4.0.12
Keywords: Cc:
Complexity: 3 Area: GUI / Usability
Module: deepamehta-webclient

Description

out of a sudden i cannot move/pan my topicmap anymore. the following error message appears at client-side when firing a mousedown-event on the canvas.

Uncaught TypeError: Cannot read property 'x' of undefined
DefaultTopicmapRenderer.topic_move_in_progressdefault_topicmap_renderer.js:515
iterate_associationsdefault_topicmap_renderer.js:739
find_associationdefault_topicmap_renderer.js:510
do_mousedowndefault_topicmap_renderer.js:416
f.event.dispatchjquery-1.7.2.min.js:3
f.event.add.h.handle.i

Change History

comment:1 Changed 8 years ago by Malte

  • Summary changed from uncaught type error to uncaught type error while panning map-panel

comment:2 Changed 8 years ago by Malte

browser is chromium 18.0.1025.168

comment:3 Changed 8 years ago by Malte

maybe this error is caused by the fact that i created another user_account with which i was logged in while trying to move a map "admin" created/owns. just a guess while thinking about it. though logging in as admin again, moving causes (this time firefox) to put out the error message:

Timestamp: 03.10.2012 02:03:30
Error: TypeError: ct2 is undefined
Source File: http://localhost:8080/de.deepamehta.webclient/script/renderers/topicmap_renderers/default_topicmap_renderer.js
Line: 515

comment:4 Changed 8 years ago by jri

I guess this canvas rendering is corrupted due to a prior error.
Have you tried reload?

(I don't think the error is related to user account issues)

comment:5 Changed 8 years ago by jri

Is this still an issue?

comment:6 Changed 8 years ago by Malte

  • Status changed from new to closed
  • Resolution set to worksforme

No, I have never encountered this error message again. I am closing this ticket now.

Note: See TracTickets for help on using tickets.