Ticket #370 (closed Defect: worksforme)

Opened 8 years ago

Last modified 8 years ago

Edit the default Topicmap for "not logged in" ...

Reported by: JuergeN Owned by: jri
Priority: Major Milestone:
Component: DeepaMehta Standard Distribution Version: 4.0.12
Keywords: Cc:
Complexity: 3 Area:
Module:

Description

How can I edit the default TopicMap? for "not-logged-in". Please check http://demo.deepamehta.de:8080/de.deepamehta.webclient . I would like to hide silkes useraccount, but whenever I return to the site, it is there, no matter what I do.

Change History

comment:1 Changed 8 years ago by jri

1) Login
2) Edit the map
3) Logout

Weather view changes (show/hide/move...) are persistent depends a) on the memberships of the user, and b) the ACL of the topicmap topic.

By default the ACL is workspace-related, that is each member within a workspace has equal permissions. Anonymous has only read permission.
If you need more info about permissions please drop a note.

comment:2 Changed 8 years ago by JuergeN

I think this is a problem with the browser caching. I noticed similar problems, when e.g. editing the contents of a text file displayed through DM filebrowser. The changes will never be displayed, because the content of the file is cached in the browser. I think you need to change the headers in terms of caching, or otherwise people will never notice any changes.

Only after deleting my entire local browser cache, the problem was solved. But this cannot be the solution.

comment:3 Changed 8 years ago by jri

Sorry, I can't reproduce the problem on the demo installation, and I don't think there is a caching issue here. For me it works exactly as described above.
(Lets talk about the text file retrieval separately. This is different.)

However, I recognized the "untitled" Topicmap got corrupted some way.

I guess your browser's error console showed a couple of errors. Please look there every time you encounter a problem and post the error log here. Please look in the server's DM logfile and post possible errors here as well.

What worries me for the moment is how the topicmap could get corrupted. Perhaps it's a multi-user issue. One user hides a topic but on another user's browser it is still visible. Perhaps we should investigate in that direction. Multi-user operation is not yet tested.

For the moment, I've deleted the corrupted "untitled" topicmap and built a new one ("Welcome"). Can you please retry the original scenario while you're the only user?

  1. login
  2. change view
  3. logout
  4. change view again
  5. login again. The topicmap must appear as arranged in step 2.

If this basically works, the original issue could be regarded as solved, and we could continue to track the multi-user operations.

Just to further isolate possible error origins: does the demo installation run via a reverse proxy or is DM's Jetty directly connected to the net?

comment:4 Changed 8 years ago by JuergeN

I tested it again, and you are right: that's ok. But I think updating file content is still an issue. I will test that again, too, and keep you updated.

comment:5 Changed 8 years ago by jri

Is this still an issue?

BTW: thanks for the nice talk recently!

comment:6 Changed 8 years ago by JuergeN

  • Status changed from new to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.