Ticket #373 (closed Defect: fixed)

Opened 8 years ago

Last modified 8 years ago

TopicType with more than 100s Instantiations cannot be edited

Reported by: Malte Owned by: jri
Priority: Major Milestone:
Component: DeepaMehta Standard Distribution Version: 4.0.12
Keywords: Cc:
Complexity: 3 Area:
Module:

Description

cannot be "edited" anymore, e.g. to change their label config, since the 100 Result-Set limitation breaks the construction of the edit form with a "TopicType? undefined" message in the browsers console.

This is most probably due to the fact that simple or composite child topics, may not be listed via the "Aggregated Definition" or "Composition Definition" caused by the result-set limitations.

Hard to put into better describgin words. Basically, everytime you click on a "TopicType?"-Topic which has already more than 100 Instantiations, the TopicType?-Definition may not be completely fetched.

Change History

comment:1 Changed 8 years ago by Malte

  • Summary changed from TopicType with more than 100s Instantiations to TopicType with more than 100s Instantiations cannot be edited

comment:2 Changed 8 years ago by Malte

For the moment, is there a place in the code-lines where i can remove the resultset limitation from the webclient as a temporary workaround? i would be thankful for this pointer atm.

comment:3 Changed 8 years ago by Malte

To reproduce this error your TopicType? needs to be such a complex one, that there are so many child topics, that there is a probability that child topics part of the composites model get filtered out by the result-set limitation (trying to describe the issue i have in more understandable words).

comment:4 Changed 8 years ago by jri

Sorry, I can't reproduce this.
I can not see why the result-set limitation should affect the type definitions or the type form.
Are you shure the result-set limitation plays a role here?
How can I reproduce this?

comment:5 Changed 8 years ago by jri

Thanks for the test link! Now the situation is clear.

That the result set limitation plays no role can you easily see when clicking *any* composite type
This result *always* is

TypeCacheError?: topic type "undefined" not found

(not "TopicType? undefined" which has a different meaning and disguised your problem even more)

The true problem is: I messed up with the branches. Meanwhile the branches are merged properly.
=> Please pull in the changes from master once more and the problem should be solved.

Plus: you get an association type editor for free :-)
To make it available a) either reset your DB or b) enter "dm4.typeeditor.assoctype_renderer" as the "Page Renderer URI" in the meta type "Association Type"'s View Configuration.

Sorry for any inconvenience.

comment:6 Changed 8 years ago by jri

Some hints for improving future error reports:

  • State the *exact* error message
  • Say what branch you're on
  • Restrict the ticket title to the obvious facts (instead of speculations)

Just simple facts so far.
A more laborious thing:

  • Try to isolate the problem and to recognize the real connections

comment:7 Changed 8 years ago by Malte

Yes, will try to take actually some time to investigate and isolate the problem before reporting next time. Thanks for your fast response and the superb assistance!

comment:8 Changed 8 years ago by Malte

  • Status changed from new to closed
  • Resolution set to fixed

comment:9 Changed 8 years ago by jri

If you have no time for investigation: no problem! I'll do the investigation.
What helps me most is just the sole simple facts.

Thanks for reporting anyway! I wasn't aware of the messed up master branch (usually I don't do that).
You're welcome.

Note: See TracTickets for help on using tickets.