Ticket #385 (closed Defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Topic keeps following the mouse

Reported by: silke Owned by: jri
Priority: Major Milestone:
Component: DeepaMehta Standard Distribution Version: 4.0.13-SNAPSHOT
Keywords: Cc:
Complexity: 3 Area: GUI / Usability
Module:

Description

I am observing this on the demo server / 4.0.13 snapshot: The topic I moved with my mouse keeps following the mouse and cannot be stuck back to the map by right-clicking.

logged error:
uncaught exception: RESTClientError: PUT request failed (error: Fetching association failed (assocTypeUri="dm4.topicmaps.topic_mapcontext", topic1Id=3369, topic2Id=6291, roleTypeUri1="dm4.core.default", roleTypeUri2="dm4.topicmaps.topicmap_topic", fetchComposite=false, clientState=null))

Change History

comment:1 Changed 7 years ago by jri

Were 2 networked users manipulating a topicmap at the same time? This is not yet fully supported.
I have to further investigate this.

Thanks for reporting!

comment:2 Changed 7 years ago by jri

Is this still an issue?

comment:3 Changed 7 years ago by silke

  • Status changed from new to closed
  • Resolution set to fixed

I can't reproduce this right now. Rolf and I edited the same topicmap simultaneously. This works fine now.

Note: See TracTickets for help on using tickets.