Ticket #485 (closed Defect: fixed)

Opened 8 years ago

Last modified 8 years ago

"Endless recursion while loading type" when instanciating topics in migration

Reported by: MK Owned by:
Priority: Major Milestone:
Component: DeepaMehta Standard Distribution Version: 4.1
Keywords: Cc: dgf, Malte
Complexity: 3 Area:
Module:

Description

see attached file

Attachments

openwifi-map-dm.zip (6.9 KB) - added by MK 8 years ago.

Change History

Changed 8 years ago by MK

comment:1 Changed 8 years ago by jri

  • Cc dgf, Malte added
  • Status changed from new to closed
  • Resolution set to fixed

comment:2 Changed 8 years ago by jri

The problem is caused by misspelling some URIs in your migrations. Sometimes "openwiki" appears when you mean "openwifi". If you fix the migrations accordingly everything goes fine.

However, your misspelled URIs revealed an underlying error in the Core's endless recursion protection mechanism. This is now fixed in the master branch. Instead of a misleading "Endless recursion" exception a proper "Topic type not found in DB" exception is now raised. See #487.

To update your installation (from the DM home directory):

git pull
mvn clean install -P all

Thank you, MK, for revealing this issue!

Note: See TracTickets for help on using tickets.