Ticket #548 (closed Defect: fixed)

Opened 7 years ago

Last modified 7 years ago

German website newsfeed is broken

Reported by: jri Owned by: rk
Priority: Major Milestone:
Component: Drupal Website Version:
Keywords: Cc: Malte, rk, JuergeN
Complexity: 3 Area: Communications
Module:

Description (last modified by jri) (diff)

The German newsfeed does not work:
http://www.deepamehta.de/de/news.xml
The XML looks like a newsfeed but all elements are empty. There is no content.
Because most news are set to be language-neutral they should appear in the German feed as well.

The English feed works fine:
http://www.deepamehta.de/en/news.xml

Change History

comment:1 Changed 7 years ago by jri

  • Description modified (diff)

comment:2 Changed 7 years ago by rk

Do we really need more than one newsfeed? If the user selected german language, opening a multiple language article with a German translation would give her what she wants. If there is no German translation, the English Article would be shown and vv.

IMHO Articles should not be "language neutral", but the language the are written in.

comment:3 Changed 7 years ago by jri

  • Cc JuergeN added

comment:4 Changed 7 years ago by jri

I agree, we do not need 2 newsfeeds.

Writing news is a cumbersome business and probably we will never write the same news in 2 languages (in fact we never did). On the other hand, news are of high interest for every DM aficionado. So I want the English news to reach the german audience too.

Even if someone is not capable of reading English news like "DM 4.2 released" or "5th DM Lounge" have a high information value for everyone. Currently the german feed subscriber never gets any news, which is not a good thing.

What I prefer: only one newsfeed which contains all news, regardless the language the news is written in. Can we configure it this way?

comment:5 Changed 7 years ago by jri

Hi rk!
Are you OK?

comment:6 follow-up: ↓ 9 Changed 7 years ago by rk

  • Status changed from new to assigned
  • Component changed from DeepaMehta Standard Distribution to Drupal Website
  • Type changed from Defect to Enhancement
  • Owner set to rk

Sorry, I was busy.

The newsfeed is not broken, there simply are no german news-articles (according to the classification of the language).

There are three things to decide:

  • If we have just one newsfeed, do we just drop the old RSS-URLs for the language-newsfeeds or keep them?
  • Do we keep the "language neutral" setting for news articles?
  • Do we translate news at all? Do we need the multi-language setting for news items?

comment:7 Changed 7 years ago by rk

Deactivated unused views: News, News. Will be deleted later, if no one complains.

comment:8 Changed 7 years ago by rk

Deactivated unused module: Feeds. We generate RSS-Feeds with views. Will be deleted later, if no one complains.

comment:9 in reply to: ↑ 6 ; follow-up: ↓ 12 Changed 7 years ago by jri

Hi rk!
Nice you're back :-)

Replying to rk:

  • If we have just one newsfeed, do we just drop the old RSS-URLs for the language-newsfeeds or keep them?

Can we keep both ...
http://www.deepamehta.de/en/news.xml
http://www.deepamehta.de/de/news.xml

... but redirect both to a new RSS-URL:
http://www.deepamehta.de/news.xml

Indeed, when we have only one feed we don't need the /en /de distinction in the URL.

Keeping (and redirecting) the old 2 URLs would leave the user's feedreader configuration intact.

In case a redirect is problematic we could drop the old 2 URLs (and require the feedreader users to reconfigure/resubscribe).

  • Do we keep the "language neutral" setting for news articles?

see below

  • Do we translate news at all? Do we need the multi-language setting for news items?

From my experience we do not translate news. So we would not need a multi-language setting for news.

Just one feed (http://www.deepamehta.de/news.xml) which contains all news items.

Thank you for the questions!

comment:10 Changed 7 years ago by jri

BTW: thank you, rk, for deleting/disabling/uninstalling/deactivating all the unused modules, content types, and views. I'm enjoying the simplified GUI. I feel as light as a feather now.

comment:11 Changed 7 years ago by rk

  • Type changed from Enhancement to Defect

Didn't know it is a regression:

https://drupal.org/node/1893756

comment:12 in reply to: ↑ 9 ; follow-up: ↓ 13 Changed 7 years ago by rk

  • Status changed from assigned to accepted

Replying to jri:

Replying to rk:

  • If we have just one newsfeed, do we just drop the old RSS-URLs for the language-newsfeeds or keep them?

Can we keep both ...
http://www.deepamehta.de/en/news.xml
http://www.deepamehta.de/de/news.xml

... but redirect both to a new RSS-URL:
http://www.deepamehta.de/news.xml

The easy fix would be, to redirect everything to http://www.deepamehta.de/en/news.xml, which we're doing from now on. Would that be a valid fix for you?

Indeed, when we have only one feed we don't need the /en /de distinction in the URL.

The problem is, that we decided to have the default English pages as /en/*. So it would try to display the broken, German feed, if you browser language preference is German.

Keeping (and redirecting) the old 2 URLs would leave the user's feedreader configuration intact.

In case a redirect is problematic we could drop the old 2 URLs (and require the feedreader users to reconfigure/resubscribe).

  • Do we keep the "language neutral" setting for news articles?

see below

  • Do we translate news at all? Do we need the multi-language setting for news items?

From my experience we do not translate news. So we would not need a multi-language setting for news.

Just one feed (http://www.deepamehta.de/news.xml) which contains all news items.

I dropped the multi language setting from news-content. It should work as desired now, but with http://www.deepamehta.de/en/news.xml as master feed.

comment:13 in reply to: ↑ 12 Changed 7 years ago by jri

Replying to rk:

The easy fix would be, to redirect everything to http://www.deepamehta.de/en/news.xml, which we're doing from now on. Would that be a valid fix for you?

Yes, this is OK for me.

I dropped the multi language setting from news-content. It should work as desired now, but with http://www.deepamehta.de/en/news.xml as master feed.

All news appear now in both feeds. So the original issue is now solved.
Very good!
Thank you very much!

comment:14 Changed 7 years ago by jri

  • Status changed from accepted to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.