Ticket #571 (closed Defect: fixed)

Opened 7 years ago

Last modified 4 years ago

File Browser: revealing file fails when retyped before

Reported by: jri Owned by: jri
Priority: Major Milestone:
Component: DeepaMehta Standard Distribution Version: 4.1.2
Keywords: Cc: dgf, Malte, JuergeN
Complexity: 3 Area:
Module: deepamehta-files

Description

Try this:

  1. Reveal an image file via File Browser
  2. Retype it to Icon
  3. Reveal the original file via File Browser again. This works. But note: from this moment on there are 2 Path topics with the same path in the DB.
  4. Try revealing the original file a 3rd time. This results in a server side error due to ambiguous Path topics:
java.lang.RuntimeException: Creating file topic for repository path "/icons/CD.png" failed
    at de.deepamehta.plugins.files.FilesPlugin.createFileTopic(FilesPlugin.java:88)
    at de.deepamehta.plugins.files.FilesPlugin.createChildFileTopic(FilesPlugin.java:129)
    ...
Caused by: java.lang.RuntimeException: Fetching topic failed (key="dm4.files.path", value="/icons/CD.png")
    at de.deepamehta.core.impl.EmbeddedService.getTopic(EmbeddedService.java:107)
    at de.deepamehta.plugins.files.FilesPlugin.fetchFileTopic(FilesPlugin.java:365)
    at de.deepamehta.plugins.files.FilesPlugin.createFileTopic(FilesPlugin.java:78)
    ...
Caused by: java.util.NoSuchElementException: More than one element in org.neo4j.index.impl.lucene.LuceneIndex$1@7ae08787. First element is 'Node[3140]' and the second element is 'Node[3076]'
    at org.neo4j.helpers.collection.IteratorUtil.singleOrNull(IteratorUtil.java:118)
    ...

Change History

comment:1 Changed 7 years ago by jri

  • Status changed from new to accepted

comment:2 Changed 7 years ago by jri

  • Milestone Release 4.1.3 deleted

comment:3 Changed 4 years ago by jri

  • Status changed from accepted to closed
  • Resolution set to fixed

Fixed in the course of #1044

Note: See TracTickets for help on using tickets.