Ticket #575 (closed Defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Long Filenames or Labels exceed the coloured Topic background on canvas

Reported by: JuergeN Owned by: jri
Priority: Major Milestone: Release 4.1.3
Component: DeepaMehta Standard Distribution Version: 4.1.2
Keywords: Cc: dgf, Malte
Complexity: 3 Area: GUI / Usability
Module:

Description

Change History

comment:1 Changed 7 years ago by jri

  • Status changed from new to accepted
  • Milestone set to Release 4.1.3

Thank you for reporting!

comment:2 Changed 7 years ago by Jörg Richter

  • Status changed from accepted to closed
  • Resolution set to fixed

Webclient: break long words (#575, #537).

Long words that doesn't fit the container are line breaked at arbitrary positions.
This is particularily useful for displaying e.g. file paths.
Breaking applies globally to the entire Webclient.

Thanks JuergeN and Malte for reporting!

Close #575.
Close #537.

comment:3 Changed 7 years ago by jri

  • Status changed from closed to reopened
  • Resolution fixed deleted

Long words still not properly breaked when appearing in the detail panel's "Related Topics" list. A horizontal scrollbar appears in the detail panel.

Possibly the cause is the topic list's table layout.

comment:4 Changed 7 years ago by jri

  • Cc dgf, Malte added

comment:5 Changed 7 years ago by Jörg Richter

  • Status changed from reopened to closed
  • Resolution set to fixed

Page Panel: fix breaking of long words (#575).

Long words (resp. filenames or such things) appearing in the detail panel's "Related Topics" list are line-breaked. No horizontal appears anymore in the detail panel.

CHANGES

The markup generated by dm4c.render.topic_list() contains no <table> anymore.

Close #575.

Note: See TracTickets for help on using tickets.