Ticket #578 (closed Task: worksforme)

Opened 7 years ago

Last modified 6 years ago

Please test DeepaMehta 4.1.3 Upgrading

Reported by: jri Owned by: jri
Priority: Major Milestone: Release 4.1.3
Component: DeepaMehta Standard Distribution Version: 4.1.2
Keywords: Cc: AsifM, Christiane, DanielP, ID, JuergeN, MK, Malte, Mimmie, admin, adrians, cke, dgf, ercrenlando1975, expertgoku, irau, jori, klieguther, ksimpson, newssubsporsoe1989, petergabiq, philipp, roedel, rk, silke, tsc, x28de, ziegi, Indie
Complexity: 3 Area:
Module:

Description

Dear users,

I would appreciate very much if you can help me testing the upgrade to upcoming DM 4.1.3. The goal is to find out weather your existing DM content is transferred without problems (it is supposed to).

You can upgrade any DM version starting from 4.1. You're not required to do each single step. That is you can update from 4.1, or 4.1.1, or 4.1.2 to 4.1.3-SNAPSHOT.

Upgrading is simple:

  1. Build DM 4.1.3-SNAPSHOT or download the nightly build binary (http://download.deepamehta.de/nightly/).
  2. Move the deepamehta-db folder from your previous installation to the 4.1.3-SNAPSHOT's home directory.
  3. Start DM 4.1.3-SNAPSHOT.

You should find all your content, including types and topicmaps in 4.1.3-SNAPSHOT exactly as it was in your previous installation.

=> If you encounter any problems please write a comment to this ticket.
Possibly send me your deepamehta-db folder.

Note: you can't upgrade from a SNAPSHOT version. The deepamehta-db folder you are testing with (step 2) must be created with a stable DM version.

DM 4.1.3 is about to be released on Dec 10 (the date of the 5th Berlin DeepaMehta Community Lounge).

Thanks
Jörg

Change History

comment:1 Changed 7 years ago by jri

  • Cc Indie added

comment:2 follow-up: ↓ 3 Changed 7 years ago by Malte

I will try this today but I won't be able to update all plugins installed (on the DB), but I guess I can differentiate between errors caused by missing plugins and errors caused by such an upgrade.

You should find all your content, including types and topicmaps in 4.1.3-SNAPSHOT exactly as it was in your previous installation.

And do you have any more hints what might not be working anymore after this an upgrade or do you think everything should be allright?

comment:3 in reply to: ↑ 2 Changed 7 years ago by jri

Replying to Malte:

And do you have any more hints what might not be working anymore after this an upgrade or do you think everything should be allright?

I think everything should be allright. But it is just not tested with real world user content.

You could look after e.g. editing topics/associations, also multiple times on the same object (testing caching behavior / timestamps). Also try editing in geomaps.

Also look after the user accounts and permissions. Everything you are able to edit you should still so in 4.1.3-SNAPSHOT and vice versa.

From 4.1 to 4.1.1 a migration runs that adapts the property URIs of the Access Control information.
From 4.1.1 to 4.1.2 is certainly painless as this contains just a small bug fix.
From 4.1.2 to 4.1.3 there are no model changes resp. no migrations running. It's supposed to be painless as well.

Thank you very much!

comment:4 Changed 7 years ago by jri

... and you could test editing topics/associations which a complex underlying model, in particular when aggregated composites are involved. 4.1.3 is the first version where this case ("aggregated composites") is supported. This is brand new stuff and involves a lot of cases: aggregation vs composition, single vs multi (cardinality), simple vs composite. And everything is composable in arbitrary depth.
However, when it works for topics it should work for associations as well (its mostly the same code).

Thank you!

comment:5 Changed 7 years ago by Malte

Sorry, it's to complex, the big eduzen-db does not provide a good testing ground since it is based on a snapshot and

  • I dont have any other db here atm +
  • I can't write my eduzen-migration now to make it a proper 4.1.2 DB

But from what I've seen so far, after upgrading 2 of my plugins, running on that DB, editing topics seems to work fine.

Cheers.

comment:6 Changed 6 years ago by jri

  • Status changed from new to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.