Ticket #615 (closed Defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Deleting an AssocDef corrupts the DB

Reported by: jri Owned by: jri
Priority: Blocker Milestone: Release 4.2
Component: DeepaMehta Standard Distribution Version: 4.1.3
Keywords: Cc: dgf, Malte, JuergeN, rk
Complexity: 3 Area:
Module: deepamehta-typeeditor

Description

Let c be the number of child types, and n be the number of the deleted assocdef (1 <= n <= c). The DB gets corrupted if n < c - 1. Fetching the parent type then fails and the Webclient does not start:

java.lang.RuntimeException: Fetching topic type "domain.project.topic_type_2733" failed
...
Caused by: java.lang.RuntimeException: Fetching sequence for type "domain.project.topic_type_2733" failed
...
Caused by: java.lang.RuntimeException: Ambiguity: there are 2 related associations (assocId=3158, assocTypeUri="dm4.core.sequence", myRoleTypeUri="dm4.core.predecessor", othersRoleTypeUri="dm4.core.successor", othersAssocTypeUri="null")

Thanks to JuergeN and rk for bringing up this issue!

Change History

comment:1 Changed 6 years ago by jri

  • Status changed from new to accepted

comment:2 Changed 6 years ago by Jörg Richter

  • Status changed from accepted to closed
  • Resolution set to fixed

Core fix: deleting assocDefs (#615).

Deleting an Association Definition does not corrupt the DB.

SEMANTIC BREAKING CHANGE

If deleting an association fails the POST_DELETE_ASSOCIATION core event is *not* fired.

Close #615.

Note: See TracTickets for help on using tickets.