Ticket #627 (closed Defect: fixed)

Opened 7 years ago

Last modified 6 years ago

editing a workspace topic via the dm4-webclient produces a crash

Reported by: Malte Owned by: jri
Priority: Major Milestone:
Component: DeepaMehta Standard Distribution Version: 4.2
Keywords: Cc:
Complexity: 3 Area:
Module:

Description

After editing e.g. the "Workspace Name" of an editable DM-Workspace, the webclient freezes and when stopping the platform via "stop 0" the attached log is produced.

This error can be reproduced when installing the latest master ref of the mapping moodle-plugin and then trying to edit the name or the description of the "ISIS / Moodle"-Workspace topic. See in the imperative Migration1 and Migration5 inthe very same plugin-repo on how this topic was intialized using DM, maybe that application-code gives a hint to better understand on how this issue could arise.

Involved Artifacts:

  • DeepaMehta 4.2 Release
  • DeepaMehta 4 Tags 1.3.6
  • org.deepamehta Reviews 0.3.4
  • Mapping Moodle Plugin 1.2-SNAPSHOT

Attachments

dm42_WS_Edit_node_type_error.txt (90.0 KB) - added by Malte 7 years ago.
First Workspace Editing Crashlog
dm42_WS_Edit_node_type_error_postUpdate.txt (75.0 KB) - added by Malte 7 years ago.
Second Workspace Editing Crashlog

Change History

Changed 7 years ago by Malte

First Workspace Editing Crashlog

Changed 7 years ago by Malte

Second Workspace Editing Crashlog

comment:1 Changed 7 years ago by Malte

Clarification:

After editing e.g. the "Workspace Name" of an editable DM-Workspace, the webclient freezes and when stopping the platform via "stop 0" the attached log is produced.

The description is maybe misleading since I have not revealed and edited one of the workspace child-topics directly. The issue occurs when editing the composite "Workspace"-Topic in the webclient.

comment:2 Changed 7 years ago by jri

  • Status changed from new to accepted

Oh, that's interesting!
I can reproduce the problem also with the standard installation. Obviously an endless recursion. I will investigate and fix this soon.
Thank you very much for reporting!

comment:3 Changed 7 years ago by jri

For the moment I found a workaround for the problem: when you edit a newly created Workspace topic in the Webclient for the first time make sure the current workspace (as selected in the toolbar) is not the one you are editing. Subsequent edits are not a problem.

comment:4 Changed 6 years ago by jri

This bug was introduced in DM 4.2 in conjunction with bubbling timestamps (see #510).
It will be fixed in DM 4.3

comment:5 Changed 6 years ago by Jörg Richter

  • Status changed from accepted to closed
  • Resolution set to fixed

Fix renaming Workspaces (#627).

Editing newly created Workspaces in the Webclient does not run into an endless recursion.

For existing workspaces you should delete the workspace assignments (Aggregation) of the Workspace Name and Workspace Description topics before editing the workspace.

Close #627

Note: See TracTickets for help on using tickets.