Ticket #684 (closed Defect: fixed)

Opened 5 years ago

Last modified 5 years ago

REST API: child topics are included in result topics even if not requested

Reported by: jri Owned by: jri
Priority: Major Milestone: Release 4.4
Component: DeepaMehta Standard Distribution Version: 4.3
Keywords: Cc: dgf, Malte, carolina
Complexity: 3 Area:
Module: deepamehta-geomaps

Description (last modified by jri) (diff)

All topics going over the wire include all their child topics, regardless if requested or not! Consequence is a serious performance penalty for large topics sets.

This is accidentally caused by the dm4-geomaps module in conjunction on-demand child topic loading (since DM 4.1!)
See #411.

Change History

comment:1 Changed 5 years ago by jri

  • Status changed from new to accepted

comment:2 Changed 5 years ago by jri

  • Description modified (diff)

comment:3 Changed 5 years ago by Jörg Richter

Geomaps: fix topic enrichment (#684).

Topics going over the wire do not include all their child topics if not requested.

This former bug -- which was caused by the dm4-geomaps module and existed since DM 4.1 -- resulted in crucial network overhead, that is more data than retuested was sent on a regular basis.

IMPORTANT: make sure your plugin does not rely on that buggy behavior, and possibly adapt it.

See #684.

comment:4 Changed 5 years ago by Jörg Richter

Geomaps: fix topic enrichment (#684).

Topics going over the wire do not include all their child topics if not requested.

This former bug -- which was caused by the dm4-geomaps module and existed since DM 4.1 -- resulted in crucial network overhead, that is more data than retuested was sent on a regular basis.

IMPORTANT: make sure your plugin does not rely on that buggy behavior, and possibly adapt it.

See #684.

comment:5 Changed 5 years ago by jri

  • Status changed from accepted to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.