Ticket #702 (closed Task: fixed)

Opened 5 years ago

Last modified 5 years ago

Core API wording: rename CompositeValue

Reported by: jri Owned by: jri
Priority: Major Milestone: Release 4.4
Component: DeepaMehta Standard Distribution Version: 4.3
Keywords: Cc:
Complexity: 3 Area: Application Framework / API
Module: deepamehta-core

Description

While explaining the Core API to others it became evident that the class CompositeValue and its accompanying composite JSON property and fetch_composite query parameters are named badly. What a CompositeValue object actually represents is a set of child topics. So the following renamings should be applied. Goal is to make the Core API more intuitive.

Classes/Interfaces?:

CompositeValue -> ChildTopics
CompositeValueModel -> ChildTopicsModel

JSON property:

composite -> childs

Query parameters:

fetch_composite -> include_childs
fetch_relating_composite -> include_assoc_childs

Change History

comment:1 Changed 5 years ago by jri

  • Status changed from new to accepted

comment:2 Changed 5 years ago by Jörg Richter

Core API wording: rename CompValue? pt.1 (#702).

BREAKING CHANGES

Classes/Interfaces?:

CompositeValue -> ChildTopics
    getCompositeValue() -> getChildTopics()
CompositeValueModel -> ChildTopicsModel
    getCompositeValueModel() -> getChildTopicsModel()

DeepaMehtaObject?:

getCompositeValue() -> getChildTopics()
setCompositeValue() -> setChildTopics()

DeepaMehtaObjectModel?:

getCompositeValueModel() -> getChildTopicsModel()
setCompositeValue() -> setChildTopicsModel()

See #702.

comment:3 Changed 5 years ago by Jörg Richter

Core API wording: rename CompValue? pt.2 (#702).

BREAKING CHANGE

The topic/association's JSON property composite is renamed to childs.

{
    "id": ..,
    "uri": ..,
    "type_uri": ..,
    "value": ..,
    "childs": ..    ### was "composite"
}

Plugin developers are supposed to carefully update the JSON migrations and client-side code.

See #702.

comment:4 Changed 5 years ago by Jörg Richter

Core API wording: rename CompValue? pt.3 (#702).

BREAKING CHANGE

REST APIs: the fetch_composite query parameter is renamed to include_childs.

Example:

GET /core/topic/1234?include_childs=true    ### "include_childs" was "fetch_composite"

Plugin developers are supposed to carefully update client-side code.

NOTE: the former fetch_relating_composite query parameter to include the (relating) association's child topics in the response is not supported at the moment. Do we actually need it in the REST APIs? If so, it should be renamed to include_assoc_childs and be implemented in the Core's JerseyResponseFilter (analogous to include_childs).

See #702.

comment:5 Changed 5 years ago by Jörg Richter

Core API wording: rename CompValue? pt.4 (#702).

Just rename variables and adapt comments.

See #702.

comment:6 Changed 5 years ago by Jörg Richter

Core API wording: rename CompValue? pt.1 (#702).

BREAKING CHANGES

Classes/Interfaces?:

CompositeValue -> ChildTopics
    getCompositeValue() -> getChildTopics()
CompositeValueModel -> ChildTopicsModel
    getCompositeValueModel() -> getChildTopicsModel()

DeepaMehtaObject?:

getCompositeValue() -> getChildTopics()
setCompositeValue() -> setChildTopics()

DeepaMehtaObjectModel?:

getCompositeValueModel() -> getChildTopicsModel()
setCompositeValue() -> setChildTopicsModel()

See #702.

comment:7 Changed 5 years ago by Jörg Richter

Core API wording: rename CompValue? pt.2 (#702).

BREAKING CHANGE

The topic/association's JSON property composite is renamed to childs.

{
    "id": ..,
    "uri": ..,
    "type_uri": ..,
    "value": ..,
    "childs": ..    ### was "composite"
}

Plugin developers are supposed to carefully update the JSON migrations and client-side code.

See #702.

comment:8 Changed 5 years ago by Jörg Richter

Core API wording: rename CompValue? pt.3 (#702).

BREAKING CHANGE

REST APIs: the fetch_composite query parameter is renamed to include_childs.

Example:

GET /core/topic/1234?include_childs=true    ### "include_childs" was "fetch_composite"

Plugin developers are supposed to carefully update client-side code.

NOTE: the former fetch_relating_composite query parameter to include the (relating) association's child topics in the response is not supported at the moment. Do we actually need it in the REST APIs? If so, it should be renamed to include_assoc_childs and be implemented in the Core's JerseyResponseFilter (analogous to include_childs).

See #702.

comment:9 Changed 5 years ago by Jörg Richter

Core API wording: rename CompValue? pt.4 (#702).

Just rename variables and adapt comments.

See #702.

comment:10 Changed 5 years ago by jri

  • Status changed from accepted to closed
  • Resolution set to fixed

comment:11 Changed 5 years ago by Jörg Richter

Core API wording: rename CompValue? pt.1 (#702).

BREAKING CHANGES

Classes/Interfaces?:

CompositeValue -> ChildTopics
    getCompositeValue() -> getChildTopics()
CompositeValueModel -> ChildTopicsModel
    getCompositeValueModel() -> getChildTopicsModel()

DeepaMehtaObject?:

getCompositeValue() -> getChildTopics()
setCompositeValue() -> setChildTopics()

DeepaMehtaObjectModel?:

getCompositeValueModel() -> getChildTopicsModel()
setCompositeValue() -> setChildTopicsModel()

See #702.

comment:12 Changed 5 years ago by Jörg Richter

Core API wording: rename CompValue? pt.2 (#702).

BREAKING CHANGE

The topic/association's JSON property composite is renamed to childs.

{
    "id": ..,
    "uri": ..,
    "type_uri": ..,
    "value": ..,
    "childs": ..    ### was "composite"
}

Plugin developers are supposed to carefully update the JSON migrations and client-side code.

See #702.

comment:13 Changed 5 years ago by Jörg Richter

Core API wording: rename CompValue? pt.3 (#702).

BREAKING CHANGE

REST APIs: the fetch_composite query parameter is renamed to include_childs.

Example:

GET /core/topic/1234?include_childs=true    ### "include_childs" was "fetch_composite"

Plugin developers are supposed to carefully update client-side code.

NOTE: the former fetch_relating_composite query parameter to include the (relating) association's child topics in the response is not supported at the moment. Do we actually need it in the REST APIs? If so, it should be renamed to include_assoc_childs and be implemented in the Core's JerseyResponseFilter (analogous to include_childs).

See #702.

comment:14 Changed 5 years ago by Jörg Richter

Core API wording: rename CompValue? pt.4 (#702).

Just rename variables and adapt comments.

See #702.

Note: See TracTickets for help on using tickets.