Ticket #708 (closed Task: wontfix)

Opened 5 years ago

Last modified 5 years ago

Java packaging: the "plugins" package should be named "plugin"

Reported by: jri Owned by: jri
Priority: Major Milestone: Release 4.4
Component: DeepaMehta Standard Distribution Version: 4.3
Keywords: Cc: dgf, Malte, carolina
Complexity: 2 Area: Application Framework / API
Module:

Description

This seems to be the better wording as a package (corresponds to a folder but) is not a folder.

Change History

comment:1 Changed 5 years ago by jri

  • Status changed from new to accepted

comment:2 Changed 5 years ago by jri

  • Status changed from accepted to closed
  • Resolution set to wontfix

This caused some discussion. As a result this ticket is withdrawn. Best practice seems to be (from http://programmers.stackexchange.com/questions/75919/should-package-names-be-singular-or-plural):

Use the plural for packages with homogeneous contents and the singular for packages with heterogeneous contents.

So, de.deepamehta.plugins is already a perfect package name as in this case its contents are all implementations of the same concept or type (= plugin), that is homogeneous.

Note: See TracTickets for help on using tickets.