Ticket #734 (closed Defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Provide default values for config properties

Reported by: jri Owned by: jri
Priority: Major Milestone: Release 4.4.1
Component: DeepaMehta Standard Distribution Version: 4.4
Keywords: Cc: dgf, Malte
Complexity: 2 Area:
Module: deepamehta-storage-neo4j

Description

When the deepamehta-standard feature is installed in a Karaf installation (via feature:install, see below) the DM config files are not in effect. In this case DM should provide reasonable default values in order to run immediately.

Currently an exception is thrown:

SEVERE: Starting "DeepaMehta 4 Storage - Neo4j" failed
java.lang.RuntimeException: Creating the Neo4j instance and indexes failed
    at de.deepamehta.storage.neo4j.Neo4jStorage.<init>(Neo4jStorage.java:95)
    at de.deepamehta.storage.neo4j.Neo4jStorageActivator.start(Neo4jStorageActivator.java:39)
    ...
Caused by: java.lang.IllegalArgumentException: Invalid value [null] for config property 'store_dir': Must be a valid file path.

Hint:
to install the deepamehta-standard feature in Karaf, execute:

feature:repo-add mvn:de.deepamehta.assemblies.features/deepamehta-standard/4.4.1-SNAPSHOT/xml/features
feature:install deepamehta-standard

See also #711

Change History

comment:1 Changed 7 years ago by jri

  • Status changed from new to accepted

comment:2 Changed 7 years ago by Jörg Richter <jri@…>

In 8cc22e9abe6abde438af6195ed5deae82232b4be/deepamehta:

Config: default for "dm4.database.path" (#734).

See #734.

comment:3 Changed 7 years ago by Jörg Richter <jri@…>

In b501e598574d8d589723166ac615a99232971dab/deepamehta:

Config: defaults for "dm4.security.*" (#734).

See #734.

comment:4 Changed 7 years ago by jri

  • Status changed from accepted to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.