Ticket #762 (closed Defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Box Renderer: Note content is not displayed when triangle is clicked

Reported by: jri Owned by: jri
Priority: Major Milestone: Release 4.6
Component: DeepaMehta Standard Distribution Version: 4.4
Keywords: Cc: dgf, Malte
Complexity: 2 Area: GUI / Usability
Module: deepamehta-box-renderer-dom

Description

When a Note topic's triangle is clicked the Note content does not appear in the topicmap. This problem only occurs when the Note content was not loaded along with the topicmap already. To reproduce:

  1. Login
  2. Close a Note topic's triangle. The "closed" state is saved.
  3. Browser reload. Now the topicmap is reloaded with no Note content.
  4. Open the Note's triangle. The Note content does not appear in the topicmap.

This bug was introduced in DM 4.4 in conjunction with changed child topics loading.

Change History

comment:1 Changed 6 years ago by jri

  • Status changed from new to accepted

comment:2 Changed 6 years ago by Jörg Richter <jri@…>

In 494b5e3db89272e077402439bc98a02730b234b1/deepamehta:

Box Renderer: fix Note topic expansion (#762).

When a Note topic's triangle is clicked the Note content does appear in the topicmap.
This was broken since 4.4 under some condition.

This commit fixes only the 4.6-SNAPSHOT line of development.
It could be cherry picked for a 4.4.x or 4.5.x bug fix release.

See #762.

comment:3 Changed 6 years ago by jri

  • Status changed from accepted to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.