Ticket #777 (closed Defect: worksforme)

Opened 7 years ago

Last modified 6 years ago

Nightly build demo server is always one build behind

Reported by: jri Owned by: JuergeN
Priority: Minor Milestone:
Component: Demo server (demo.deepamehta.de) Version:
Keywords: Cc:
Complexity: 3 Area: Communications
Module:

Description

It seems the nightly build demo server does not run the latest build but the second-latest build.
http://demo.deepamehta.de:8083/de.deepamehta.webclient

The current commit (as of March 27, 3 a.m.) is not deployed but the previous one is.
I think this is a general pattern.

Change History

comment:1 Changed 7 years ago by jri

Oh, I just saw the mentioned commit was indeed problematic. The build failed.
This is now fixed.

Sorry for possible false alert.
I'll keep observing.

comment:2 Changed 7 years ago by jri

Today (Mar 29) the release as of Mar 28 is supposed to be deployed (the new Phone/Address? model, #779) but the release of Mar 27 is.

comment:3 Changed 6 years ago by jri

The current DM version is of Apr 25 and at the moment this version is deployed too.
Possibly the problem is gone now. Possibly the Jenkins "timezone" was the culprit.
I'll keep watching.
Thank you very much!

comment:4 Changed 6 years ago by jri

I better should have checked that yesterday (Apr 26). Anyways ... I'll keep watching.

comment:5 Changed 6 years ago by jri

Today (Apr 28) the release as of Apr 27 is deployed.
So, this looks good!

comment:6 Changed 6 years ago by jri

Today (May 6) the release as of May 5 is supposed to be deployed [f352bacd] but the release of Apr 27 is.
So, the problem is still there.

comment:7 Changed 6 years ago by jri

Today (May 7) the release as of Apr 27 is still deployed, neither May 5's nor May 6's one.
Deployment is now 2 releases behind.

comment:8 Changed 6 years ago by jri

Today (May 8) the release as of Apr 27 is still deployed.
Deployment is now 3 releases behind (May 5, 6, 7).
Is auto-deployment still working?

comment:9 Changed 6 years ago by JuergeN

Somehoe Jenkins stopped to work after April 27th. I have recently reset the server. Todays nighly is from May 12th, which looks promising. Let's see how it goes on ...

comment:10 Changed 6 years ago by jri

Today (May 20) the release as of May 19 is deployed.
So, this looks good!

comment:11 Changed 6 years ago by JuergeN

OK. So let's check this once again tomrrow and then we can close this ticket. ;-)

comment:12 Changed 6 years ago by jri

OK, I'll check once the next commit is made.

comment:13 Changed 6 years ago by jri

BTW: the demo server seems to have quite a short session timeout of about 5 min.
For a DM server installation a session timeout is reasonable indeed. We could consider increasing it to 60 min or so.
I'm just curious because the DM default installation sets no session timeout.

comment:14 Changed 6 years ago by jri

  • Status changed from new to closed
  • Resolution set to worksforme

Thank you, JuergeN!

Note: See TracTickets for help on using tickets.