Ticket #792 (closed Defect: fixed)

Opened 7 years ago

Last modified 7 years ago

HTML child topics with cardinality "Many" let the Webclient crash

Reported by: jri Owned by: jri
Priority: Blocker Milestone: Release 4.6
Component: DeepaMehta Standard Distribution Version: 4.5
Keywords: Cc: dgf, Malte, JuergeN
Complexity: 3 Area:
Module: deepamehta-webclient

Description

The detail panel's form rendering is broken if the type definition of the selected topic/association includes HTML child topics with cardinality "Many". The problem is related to CKEditor instantiation.

The browser console shows an error like this:

The editor instance "field_/dm4.contacts.person/dm4.contacts.notes" is already attached to the provided element.

Change History

comment:1 Changed 7 years ago by jri

  • Status changed from new to accepted

comment:2 Changed 7 years ago by Jörg Richter <jri@…>

In f2c07c277191c4a020cee491effcd5e73c5cef9d/deepamehta:

Webclient: HTML childs with card. "many" (#792).

The detail panel's form rendering works also if the type definition of the selected topic/association includes child topics of data type "HTML" and cardinality "Many".

Thank you very much, Juergen, for reporting!

See #792.

comment:3 Changed 7 years ago by jri

  • Status changed from accepted to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.