Ticket #80 (closed Defect: fixed)

Opened 9 years ago

Last modified 9 years ago

Data type "Number" not fully supported

Reported by: irau Owned by: jri
Priority: Major Milestone: Release 4.1
Component: DeepaMehta Standard Distribution Version: 4.0.3
Keywords: Cc:
Complexity: 3 Area: GUI
Module: deepamehta-webclient

Description

I created a topic type "car" and defined the data type as composite. I then created the topic types "Description", "Model", "Year of Construction", "Date of Purchase", "Color" and "Chassis Number".

When I tried to create a new "car" the attached error message was displayed. I assume the problem is cased by the data type "number" I chose for "Year of Construction" an "Chassis Number" (although I solely entered Integers when creating the "car" topic).

Attachments

number_error_message.jpg (45.5 KB) - added by irau 9 years ago.

Change History

Changed 9 years ago by irau

comment:1 Changed 9 years ago by jri

  • Status changed from new to accepted
  • Complexity changed from 3 to 2
  • Module set to deepamehta-webclient
  • Milestone set to Release 4.1

comment:2 Changed 9 years ago by jri

  • Complexity changed from 2 to 3
  • Summary changed from Problems with composite topic type associating a topic type with data type number to Data type "Number" not fully supported
  • Area set to GUI

comment:3 Changed 9 years ago by jri

Core/Webclient? fix: Data type "Number" (#80).

Number fields work now.

One issue remains: for aggregated number types no combobox is rendered.

Changeset [7cf3f4d5]

comment:4 Changed 9 years ago by jri

  • Status changed from accepted to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.