Ticket #821 (closed Task: fixed)

Opened 6 years ago

Last modified 6 years ago

dm4-images: upgrade plugin to be compatible with 4.7.x

Reported by: Malte Owned by: Malte
Priority: Minor Milestone:
Component: 3rd Party Plugins Version: 4.6.1
Keywords: Cc:
Complexity: 2 Area:
Module:

Change History

comment:1 Changed 6 years ago by Malte

  • Status changed from new to accepted

Migrated installation logic from postInstall() to a new Migration1, as required by DM 4.5+.

comment:2 Changed 6 years ago by Malte

Needs to be adapted to #815 and react up on the new system setting:

dm4.filerepo.per_workspace=false|true

Esp. folders cannot be created in migration anymore but need to be created on demand (that is, on the first request involving them).

comment:3 Changed 6 years ago by Malte

  • Summary changed from dm4-images: upgrade plugin to be compatible with 4.6.x to dm4-images: upgrade plugin to be compatible with 4.7.x

comment:4 Changed 6 years ago by Malte

  • Status changed from accepted to closed
  • Resolution set to fixed

This was successfully done and released for download here:
https://download.deepamehta.de/nightly/dm47-deepamehta-images-0.9.6.jar

Though it is not recommended because it contains a nasty rendering bug which distorts all images bigger than the page panel. A new release where this bug was fixed is released and will be available by tomorrow at: https://download.deepamehta.de/nightly/dm47-deepamehta-images-0.9.7.jar

comment:5 Changed 6 years ago by Malte

  • Status changed from closed to reopened
  • Resolution fixed deleted

The docs on CKeditor.com on all dependencies per plugin is not very nice. After running in the following issue i can confirm that the "File Browser" addon was also a dependency when we sucessfully extend the old (formerly used) "image" plugin of the CKEditor.

Having setup a succesfull image upload and browse dialog with CKEditor and both images plugins now, i have difficulties to understand this completely new exception (triggered by an upload request tested with both types image modules, "image" and "image2").

19.04.2016 17:40:29 de.deepamehta.files.provider.UploadedFileProvider parseMultiPart
INFO: ### Parsing multipart/form-data request (2 parts)
19.04.2016 17:40:29 de.deepamehta.files.provider.UploadedFileProvider parseMultiPart
INFO: ### field "upload" => file "CgEFfl4UUAAl6Qb.jpg:large.jpeg" (image/jpeg, 126734 bytes)
19.04.2016 17:40:29 de.deepamehta.files.provider.UploadedFileProvider parseMultiPart
INFO: ### field "ckCsrfToken" => "r1rMJrTebz9qbY5GrUNDpzy55IFAVRcyN39VSdrf"
19.04.2016 17:40:29 de.deepamehta.core.util.UniversalExceptionMapper logException
SCHWERWIEGEND: Request "POST /images/upload?CKEditor=editor1&CKEditorFuncNum=0&langCode=en" failed. Responding with 500 (Internal Server Error). The original exception/error is:
java.lang.RuntimeException: Creating UploadedFile from message body failed
	at de.deepamehta.files.provider.UploadedFileProvider.readFrom(UploadedFileProvider.java:62)
	at de.deepamehta.files.provider.UploadedFileProvider.readFrom(UploadedFileProvider.java:35)
	at com.sun.jersey.spi.container.ContainerRequest.getEntity(ContainerRequest.java:488)
	at com.sun.jersey.server.impl.model.method.dispatch.EntityParamDispatchProvider$EntityInjectable.getValue(EntityParamDispatchProvider.java:123)
	at com.sun.jersey.server.impl.inject.InjectableValuesProvider.getInjectableValues(InjectableValuesProvider.java:46)
	at com.sun.jersey.server.impl.model.method.dispatch.AbstractResourceMethodDispatchProvider$EntityParamInInvoker.getParams(AbstractResourceMethodDispatchProvider.java:153)
	at com.sun.jersey.server.impl.model.method.dispatch.AbstractResourceMethodDispatchProvider$TypeOutInvoker._dispatch(AbstractResourceMethodDispatchProvider.java:183)
	at com.sun.jersey.server.impl.model.method.dispatch.ResourceJavaMethodDispatcher.dispatch(ResourceJavaMethodDispatcher.java:75)
	at com.sun.jersey.server.impl.uri.rules.HttpMethodRule.accept(HttpMethodRule.java:302)
	at com.sun.jersey.server.impl.uri.rules.RightHandPathRule.accept(RightHandPathRule.java:147)
	at com.sun.jersey.server.impl.uri.rules.ResourceObjectRule.accept(ResourceObjectRule.java:100)
	at com.sun.jersey.server.impl.uri.rules.RightHandPathRule.accept(RightHandPathRule.java:147)
	at com.sun.jersey.server.impl.uri.rules.RootResourceClassesRule.accept(RootResourceClassesRule.java:84)
	at com.sun.jersey.server.impl.application.WebApplicationImpl._handleRequest(WebApplicationImpl.java:1480)
	at com.sun.jersey.server.impl.application.WebApplicationImpl._handleRequest(WebApplicationImpl.java:1411)
	at com.sun.jersey.server.impl.application.WebApplicationImpl.handleRequest(WebApplicationImpl.java:1360)
	at com.sun.jersey.server.impl.application.WebApplicationImpl.handleRequest(WebApplicationImpl.java:1350)
	at com.sun.jersey.spi.container.servlet.WebComponent.service(WebComponent.java:416)
	at com.sun.jersey.spi.container.servlet.ServletContainer.service(ServletContainer.java:538)
	at com.sun.jersey.spi.container.servlet.ServletContainer.service(ServletContainer.java:716)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:722)
	at org.apache.felix.http.base.internal.handler.ServletHandler.doHandle(ServletHandler.java:339)
	at org.apache.felix.http.base.internal.handler.ServletHandler.handle(ServletHandler.java:300)
	at org.apache.felix.http.base.internal.dispatch.ServletPipeline.handle(ServletPipeline.java:93)
	at org.apache.felix.http.base.internal.dispatch.InvocationFilterChain.doFilter(InvocationFilterChain.java:50)
	at org.apache.felix.http.base.internal.dispatch.HttpFilterChain.doFilter(HttpFilterChain.java:31)
	at org.apache.felix.http.base.internal.dispatch.FilterPipeline.dispatch(FilterPipeline.java:76)
	at org.apache.felix.http.base.internal.dispatch.Dispatcher.dispatch(Dispatcher.java:49)
	at org.apache.felix.http.base.internal.DispatcherServlet.service(DispatcherServlet.java:67)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:722)
	at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:684)
	at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:501)
	at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:229)
	at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1086)
	at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:428)
	at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:193)
	at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1020)
	at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:135)
	at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:255)
	at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:116)
	at org.eclipse.jetty.server.Server.handle(Server.java:370)
	at org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(AbstractHttpConnection.java:494)
	at org.eclipse.jetty.server.AbstractHttpConnection.content(AbstractHttpConnection.java:982)
	at org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.content(AbstractHttpConnection.java:1043)
	at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:865)
	at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:240)
	at org.eclipse.jetty.server.AsyncHttpConnection.handle(AsyncHttpConnection.java:82)
	at org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:667)
	at org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:52)
	at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:608)
	at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:543)
	at java.lang.Thread.run(Thread.java:701)
Caused by: java.lang.RuntimeException: Parsing multipart/form-data request failed
	at de.deepamehta.files.provider.UploadedFileProvider.parseMultiPart(UploadedFileProvider.java:110)
	at de.deepamehta.files.provider.UploadedFileProvider.readFrom(UploadedFileProvider.java:60)
	... 51 more
Caused by: java.lang.RuntimeException: "ckCsrfToken" is an unexpected field (value="r1rMJrTebz9qbY5GrUNDpzy55IFAVRcyN39VSdrf")
	at de.deepamehta.files.provider.UploadedFileProvider.parseMultiPart(UploadedFileProvider.java:95)
	... 52 more
19.04.2016 17:40:29 de.deepamehta.core.impl.TransactionFactory$TransactionResourceFilter$2 filter
WARNUNG: ### Rollback transaction of de.deepamehta.plugins.images.ImagePlugin#upload()

Any ideas how this could happen? Is this new field part of a changed HTML Form used in CKEditors upload dialog or what? Thankful for any hints.

comment:6 Changed 6 years ago by Malte

Oops. Sorry for reopening this, wrong ticket.

comment:7 Changed 6 years ago by Malte

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.