Ticket #91 (closed Defect: fixed)

Opened 9 years ago

Last modified 9 years ago

File management doesn't work on Windows

Reported by: irau Owned by: jri
Priority: Major Milestone: Release 4.1
Component: DeepaMehta Standard Distribution Version: 4.0.3
Keywords: Cc: Malte
Complexity: 3 Area:
Module:

Description (last modified by jri) (diff)

12.09.2011 15:55:38 de.deepamehta.plugins.proxy.ProxyPlugin? getResource
INFO: Requesting resource "file:/" (mediaType="null", size=0)
12.09.2011 15:55:38 de.deepamehta.plugins.proxy.ProxyPlugin? checkRemoteAccess
INFO: Checking remote access to "http://localhost:8080/proxy/file%3A%2F"

remote address="127.0.0.1", range="127.0.0.1/32" => ALLOWED

12.09.2011 15:55:38 de.deepamehta.plugins.proxy.ProxyPlugin? checkFileAccess
INFO: Checking file repository access to "\"

dm4.proxy.files.path="", canonical request path="C:\" => ALLOWED

12.09.2011 15:55:38 de.deepamehta.core.impl.service.EmbeddedService? getRelatedTo
pics
INFO: topicId=2076, assocTypeUri="null", myRoleTypeUri="null", othersRoleTypeUri
="null", othersTopicTypeUri="null"
12.09.2011 15:55:52 de.deepamehta.core.impl.service.EmbeddedService? getAssociati
ons
INFO: topic1Id=2076, topic2Id=2106, assocTypeUri="dm4.core.aggregation"
12.09.2011 15:55:52 de.deepamehta.core.impl.service.EmbeddedService? getAssociati
ons
INFO: topic1Id=2076, topic2Id=2106, assocTypeUri="null"
12.09.2011 15:55:52 de.deepamehta.plugins.proxy.ProxyPlugin? getResource
INFO: Requesting resource "file:C:/Dokumente und Einstellungen" (mediaType="null
", size=0)
12.09.2011 15:55:52 de.deepamehta.plugins.proxy.ProxyPlugin? checkRemoteAccess
INFO: Checking remote access to "http://localhost:8080/proxy/file%3AC%3A%5CDokum
ente%20und%20Einstellungen"

remote address="127.0.0.1", range="127.0.0.1/32" => ALLOWED

12.09.2011 15:55:52 com.sun.jersey.spi.container.ContainerResponse? mapMappableCo
ntainerException
SCHWERWIEGEND: The RuntimeException? could not be mapped to a response, re-throwi
ng to the HTTP container
java.lang.RuntimeException?: Checking file repository access failed (file="\C:\Do
kumente und Einstellungen")

at de.deepamehta.plugins.proxy.ProxyPlugin?.checkFileAccess(ProxyPlugin?.j

ava:142)

at de.deepamehta.plugins.proxy.ProxyPlugin?.locateFile(ProxyPlugin?.java:9

3)

at de.deepamehta.plugins.proxy.ProxyPlugin?.getResource(ProxyPlugin?.java:

65)

at sun.reflect.NativeMethodAccessorImpl?.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl?.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl?.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.sun.jersey.spi.container.JavaMethodInvokerFactory?$1.invoke(JavaMe?

thodInvokerFactory.java:60)

at com.sun.jersey.server.impl.model.method.dispatch.AbstractResourceMeth?

odDispatchProvider$TypeOutInvoker?._dispatch(AbstractResourceMethodDispatchProvid?
er.java:185)

at com.sun.jersey.server.impl.model.method.dispatch.ResourceJavaMethodDi?

spatcher.dispatch(ResourceJavaMethodDispatcher?.java:75)

at com.sun.jersey.server.impl.uri.rules.HttpMethodRule?.accept(HttpMethod?

Rule.java:288)

at com.sun.jersey.server.impl.uri.rules.RightHandPathRule?.accept(RightHa?

ndPathRule.java:147)

at com.sun.jersey.server.impl.uri.rules.ResourceObjectRule?.accept(Resour

ceObjectRule.java:100)

at com.sun.jersey.server.impl.uri.rules.RightHandPathRule?.accept(RightHa?

ndPathRule.java:147)

at com.sun.jersey.server.impl.uri.rules.RootResourceClassesRule?.accept(R

ootResourceClassesRule.java:84)

at com.sun.jersey.server.impl.application.WebApplicationImpl?._handleRequ

est(WebApplicationImpl?.java:1469)

at com.sun.jersey.server.impl.application.WebApplicationImpl?._handleRequ

est(WebApplicationImpl?.java:1400)

at com.sun.jersey.server.impl.application.WebApplicationImpl?.handleReque

st(WebApplicationImpl?.java:1349)

at com.sun.jersey.server.impl.application.WebApplicationImpl?.handleReque

st(WebApplicationImpl?.java:1339)

at com.sun.jersey.spi.container.servlet.WebComponent?.service(WebComponen?

t.java:416)

at com.sun.jersey.spi.container.servlet.ServletContainer?.service(Servlet

Container.java:537)

at com.sun.jersey.spi.container.servlet.ServletContainer?.service(Servlet

Container.java:699)

at javax.servlet.http.HttpServlet?.service(HttpServlet?.java:820)
at org.apache.felix.http.base.internal.handler.ServletHandler?.doHandle(S

ervletHandler.java:96)

at org.apache.felix.http.base.internal.handler.ServletHandler?.handle(Ser

vletHandler.java:79)

at org.apache.felix.http.base.internal.dispatch.ServletPipeline?.handle(S

ervletPipeline.java:42)

at org.apache.felix.http.base.internal.dispatch.InvocationFilterChain?.do

Filter(InvocationFilterChain?.java:49)

at org.apache.felix.http.base.internal.dispatch.HttpFilterChain?.doFilter

(HttpFilterChain?.java:33)

at org.apache.felix.http.base.internal.dispatch.FilterPipeline?.dispatch(

FilterPipeline?.java:48)

at org.apache.felix.http.base.internal.dispatch.Dispatcher.dispatch(Disp

atcher.java:39)

at org.apache.felix.http.base.internal.DispatcherServlet?.service(Dispatc

herServlet.java:67)

at javax.servlet.http.HttpServlet?.service(HttpServlet?.java:820)
at org.mortbay.jetty.servlet.ServletHolder?.handle(ServletHolder?.java:511

)

at org.mortbay.jetty.servlet.ServletHandler?.handle(ServletHandler?.java:3

90)

at org.mortbay.jetty.servlet.SessionHandler?.handle(SessionHandler?.java:1

82)

at org.mortbay.jetty.handler.ContextHandler?.handle(ContextHandler?.java:7

65)

at org.mortbay.jetty.handler.HandlerWrapper?.handle(HandlerWrapper?.java:1

52)

at org.mortbay.jetty.Server.handle(Server.java:326)
at org.mortbay.jetty.HttpConnection?.handleRequest(HttpConnection?.java:54

2)

at org.mortbay.jetty.HttpConnection?$RequestHandler?.headerComplete(HttpCo?

nnection.java:926)

at org.mortbay.jetty.HttpParser?.parseNext(HttpParser?.java:549)
at org.mortbay.jetty.HttpParser?.parseAvailable(HttpParser?.java:212)
at org.mortbay.jetty.HttpConnection?.handle(HttpConnection?.java:404)
at org.mortbay.io.nio.SelectChannelEndPoint?.run(SelectChannelEndPoint?.ja

va:410)

at org.mortbay.thread.QueuedThreadPool?$PoolThread?.run(QueuedThreadPool?.j

ava:582)
Caused by: java.io.IOException: Die Syntax f├╝r den Dateinamen, Verzeichnisnamen

oder die Datenträgerbezeichnung ist falsch

at java.io.WinNTFileSystem.canonicalize0(Native Method)
at java.io.Win32FileSystem.canonicalize(Unknown Source)
at java.io.File.getCanonicalPath(Unknown Source)
at de.deepamehta.plugins.proxy.ProxyPlugin?.checkFileAccess(ProxyPlugin?.j

ava:122)

... 44 more

[WARNING] /proxy/file%3AC%3A%5CDokumente%20und%20Einstellungen
java.lang.RuntimeException?: Checking file repository access failed (file="\C:\Do
kumente und Einstellungen")

at de.deepamehta.plugins.proxy.ProxyPlugin?.checkFileAccess(ProxyPlugin?.j

ava:142)

at de.deepamehta.plugins.proxy.ProxyPlugin?.locateFile(ProxyPlugin?.java:9

3)

at de.deepamehta.plugins.proxy.ProxyPlugin?.getResource(ProxyPlugin?.java:

65)

at sun.reflect.NativeMethodAccessorImpl?.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl?.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl?.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.sun.jersey.spi.container.JavaMethodInvokerFactory?$1.invoke(JavaMe?

thodInvokerFactory.java:60)

at com.sun.jersey.server.impl.model.method.dispatch.AbstractResourceMeth?

odDispatchProvider$TypeOutInvoker?._dispatch(AbstractResourceMethodDispatchProvid?
er.java:185)

at com.sun.jersey.server.impl.model.method.dispatch.ResourceJavaMethodDi?

spatcher.dispatch(ResourceJavaMethodDispatcher?.java:75)

at com.sun.jersey.server.impl.uri.rules.HttpMethodRule?.accept(HttpMethod?

Rule.java:288)

at com.sun.jersey.server.impl.uri.rules.RightHandPathRule?.accept(RightHa?

ndPathRule.java:147)

at com.sun.jersey.server.impl.uri.rules.ResourceObjectRule?.accept(Resour

ceObjectRule.java:100)

at com.sun.jersey.server.impl.uri.rules.RightHandPathRule?.accept(RightHa?

ndPathRule.java:147)

at com.sun.jersey.server.impl.uri.rules.RootResourceClassesRule?.accept(R

ootResourceClassesRule.java:84)

at com.sun.jersey.server.impl.application.WebApplicationImpl?._handleRequ

est(WebApplicationImpl?.java:1469)

at com.sun.jersey.server.impl.application.WebApplicationImpl?._handleRequ

est(WebApplicationImpl?.java:1400)

at com.sun.jersey.server.impl.application.WebApplicationImpl?.handleReque

st(WebApplicationImpl?.java:1349)

at com.sun.jersey.server.impl.application.WebApplicationImpl?.handleReque

st(WebApplicationImpl?.java:1339)

at com.sun.jersey.spi.container.servlet.WebComponent?.service(WebComponen?

t.java:416)

at com.sun.jersey.spi.container.servlet.ServletContainer?.service(Servlet

Container.java:537)

at com.sun.jersey.spi.container.servlet.ServletContainer?.service(Servlet

Container.java:699)

at javax.servlet.http.HttpServlet?.service(HttpServlet?.java:820)
at org.apache.felix.http.base.internal.handler.ServletHandler?.doHandle(S

ervletHandler.java:96)

at org.apache.felix.http.base.internal.handler.ServletHandler?.handle(Ser

vletHandler.java:79)

at org.apache.felix.http.base.internal.dispatch.ServletPipeline?.handle(S

ervletPipeline.java:42)

at org.apache.felix.http.base.internal.dispatch.InvocationFilterChain?.do

Filter(InvocationFilterChain?.java:49)

at org.apache.felix.http.base.internal.dispatch.HttpFilterChain?.doFilter

(HttpFilterChain?.java:33)

at org.apache.felix.http.base.internal.dispatch.FilterPipeline?.dispatch(

FilterPipeline?.java:48)

at org.apache.felix.http.base.internal.dispatch.Dispatcher.dispatch(Disp

atcher.java:39)

at org.apache.felix.http.base.internal.DispatcherServlet?.service(Dispatc

herServlet.java:67)

at javax.servlet.http.HttpServlet?.service(HttpServlet?.java:820)
at org.mortbay.jetty.servlet.ServletHolder?.handle(ServletHolder?.java:511

)

at org.mortbay.jetty.servlet.ServletHandler?.handle(ServletHandler?.java:3

90)

at org.mortbay.jetty.servlet.SessionHandler?.handle(SessionHandler?.java:1

82)

at org.mortbay.jetty.handler.ContextHandler?.handle(ContextHandler?.java:7

65)

at org.mortbay.jetty.handler.HandlerWrapper?.handle(HandlerWrapper?.java:1

52)

at org.mortbay.jetty.Server.handle(Server.java:326)
at org.mortbay.jetty.HttpConnection?.handleRequest(HttpConnection?.java:54

2)

at org.mortbay.jetty.HttpConnection?$RequestHandler?.headerComplete(HttpCo?

nnection.java:926)

at org.mortbay.jetty.HttpParser?.parseNext(HttpParser?.java:549)
at org.mortbay.jetty.HttpParser?.parseAvailable(HttpParser?.java:212)
at org.mortbay.jetty.HttpConnection?.handle(HttpConnection?.java:404)
at org.mortbay.io.nio.SelectChannelEndPoint?.run(SelectChannelEndPoint?.ja

va:410)

at org.mortbay.thread.QueuedThreadPool?$PoolThread?.run(QueuedThreadPool?.j

ava:582)
Caused by: java.io.IOException: Die Syntax f├╝r den Dateinamen, Verzeichnisnamen

oder die Datenträgerbezeichnung ist falsch

at java.io.WinNTFileSystem.canonicalize0(Native Method)
at java.io.Win32FileSystem.canonicalize(Unknown Source)
at java.io.File.getCanonicalPath(Unknown Source)
at de.deepamehta.plugins.proxy.ProxyPlugin?.checkFileAccess(ProxyPlugin?.j

ava:122)

... 44 more

12.09.2011 15:55:52 de.deepamehta.core.impl.service.EmbeddedService? getRelatedTo
pics
INFO: topicId=2106, assocTypeUri="null", myRoleTypeUri="null", othersRoleTypeUri
="null", othersTopicTypeUri="null"

Change History

comment:1 Changed 9 years ago by jri

  • Status changed from new to accepted
  • Cc Malte added
  • Milestone set to Release 4.1
  • Description modified (diff)
  • Summary changed from Drag 'n Drop file on canvas causes error to File management doesn't work on Windows

comment:2 Changed 9 years ago by JuergeN

Are there any updates on this issue? Does it work now?

comment:3 Changed 9 years ago by jri

No progress for the moment.

At the todays meeting Ingo will hand me over a Windows Laptop for me to use as a testing machine.
If everything goes fine the Windows fix could be provided within this week, as part of a 4.0.5 release.

comment:4 Changed 9 years ago by irau

Hi Jörg,
since the windows laptop is currently at our new office in Parkstrasse it would be easier for me to give it to you tomorrow. We will be at Parkstraße at around 19.00. Would that be ok for you?

comment:5 Changed 9 years ago by Jörg Richter

Proxy module: fix Windows path problem (#91).

All file related features should now work properly on Windows too.

See ticket 91.

comment:6 Changed 9 years ago by jri

The file browser feature is now working on Windows.
A snapshot release is here:
https://github.com/downloads/jri/deepamehta/deepamehta-4.0.5-20111014.zip

Drag'n'drop files from the Windows Explorer still does *not* work.

comment:7 Changed 9 years ago by Jörg Richter

Files module: fix Windows file drag'n'drop (#91).

Note: draging'n'dropping files from arbitrary locations (in particular different Windows drives) collides with the concept of a single-rooted file repository (as realized by the proxy module). For the moment on Windows drag'n'drop operations are only supported from the C: drive (actually the drive DM is started from).

Re-conceptualization is required.

See ticket 91.

Last edited 9 years ago by jri (previous) (diff)

comment:8 Changed 9 years ago by jri

Drag'n'drop files from the Windows Explorer now works.
(Since yesterday the file browser feature works as well.)
The Windows file related fixes are regarded as complete for the moment.

A new snapshot release is available:
https://github.com/downloads/jri/deepamehta/deepamehta-4.0.5-20111015.zip

If you've already downloaded this one today before 16:30 please re-download.

comment:9 Changed 9 years ago by jri

  • Status changed from accepted to closed
  • Resolution set to fixed

comment:10 Changed 9 years ago by Jörg Richter

Proxy module: fix Windows path problem (#91).

All file related features should now work properly on Windows too.

See ticket 91.

comment:11 Changed 9 years ago by Jörg Richter

Files module: fix Windows file drag'n'drop (#91).

Note: draging'n'dropping files from arbitrary locations (in particular different Windows drives) collides with the concept of a single-rooted file repository (as realized by the proxy module). For the moment on Windows drag'n'drop operations are only supported from the C: drive (actually the drive DM is started from).

See ticket 91.

Note: See TracTickets for help on using tickets.