Ticket #930 (closed Defect: worksforme)

Opened 5 years ago

Last modified 5 years ago

dm4-images: broken images due to "localhost" being return by the server in the image-path

Reported by: Malte Owned by: Malte
Priority: Blocker Milestone: Release 4.8
Component: 3rd Party Plugins Version: 4.7
Keywords: Cc: JuergeN
Complexity: 3 Area:
Module:

Description

Thanks JuergeN for testing and reporting this issue!

Change History

comment:1 Changed 5 years ago by Malte

The issue is, the current implementation adapts the image paths according to the value in "javax.ws.rs.core.UriInfo?;", which is fine for most cases. But when the service runs behind a reverse proxy, the baseUri of the request URI (localhost) does not match the baseUri (e.g. my.deepamehta.de) where the application is served on.

Implementation will be changed to rely solely on a properly configured "dm4.host.url" by the administrator/user. The port is to be neglected and must always be :80 when using the dm4-images plugin since (to my knowledge) there is there is no place where it could be configured currectly. Example is the myDM setup: The dm4-platform is configured to be served on :8085 but https://my.deepamehta.de:8085 is unreachable and there is currently no 2nd place where we (would want to) configure such a port (currently).

Consequentl the next release will be a compromise solely for the deployment on the myDM platform.

comment:2 Changed 5 years ago by Malte

  • Status changed from new to closed
  • Resolution set to worksforme

Changed and released, see http://download.deepamehta.de/nightly/

Note: See TracTickets for help on using tickets.