Changes between Initial Version and Version 2 of Ticket #941


Ignore:
Timestamp:
28.02.2016 16:20:01 (6 years ago)
Author:
jri
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #941

    • Property Status changed from new to accepted
    • Property Summary changed from Consolidate API wording to Consolidate Core API
  • Ticket #941 – Description

    initial v2  
    22 
    33List of intended API changes: 
     4 
    45* The `DeepaMehtaService` interface should be named `CoreService`. Consequently the omnipresent `dms` object should be named `cs`. 
     6 
    57* The !DeepaMehtaService's `deliverEvent()` method should be named `dispatchEvent()`. 
     8 
    69* The !DeepaMehtaService's various `getTopic[s]` methods possibly could have more telling names, e.g. `getTopicById()`. 
     10 
     11* The !ChildTopicModel's `getTopic[s]` methods should have the same form as its counterparts in !ChildTopics. The forms that take default value should be transformed into `getTopic[s]OrNull` (that is a fixed default value of `null`). All forms should catch and report a `ClassCastException`. 
     12 
    713* //to be continued ... you proposals here ...//