Ticket #967 (closed Task: worksforme)

Opened 6 years ago

Last modified 5 years ago

dm4-thymeleaf built from source: class not found error when starting bundle

Reported by: Malte Owned by: jri
Priority: Major Milestone: Release 4.8.1
Component: 3rd Party Plugins Version: 4.8
Keywords: Cc: jri
Complexity: 2 Area:
Module:

Description

While needing to extend the dm4-sign-up module i have trouble getting the dm48-thymeleaf-0.5.jar to start when building it from the sources. Here is the error i got after typing "start bundleId" into the GoGo? Shell.

org.osgi.framework.BundleException: Activator start error in bundle de.deepamehta.webactivator [18].
	at org.apache.felix.framework.Felix.activateBundle(Felix.java:2204)
	at org.apache.felix.framework.Felix.startBundle(Felix.java:2072)
	at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:976)
	at org.apache.felix.gogo.command.Basic.start(Basic.java:729)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:622)
	at org.apache.felix.gogo.runtime.Reflective.invoke(Reflective.java:137)
	at org.apache.felix.gogo.runtime.CommandProxy.execute(CommandProxy.java:82)
	at org.apache.felix.gogo.runtime.Closure.executeCmd(Closure.java:477)
	at org.apache.felix.gogo.runtime.Closure.executeStatement(Closure.java:403)
	at org.apache.felix.gogo.runtime.Pipe.run(Pipe.java:108)
	at org.apache.felix.gogo.runtime.Closure.execute(Closure.java:183)
	at org.apache.felix.gogo.runtime.Closure.execute(Closure.java:120)
	at org.apache.felix.gogo.runtime.CommandSessionImpl.execute(CommandSessionImpl.java:89)
	at org.apache.felix.gogo.shell.Console.run(Console.java:62)
	at org.apache.felix.gogo.shell.Shell.console(Shell.java:203)
	at org.apache.felix.gogo.shell.Shell.gosh(Shell.java:128)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:622)
	at org.apache.felix.gogo.runtime.Reflective.invoke(Reflective.java:137)
	at org.apache.felix.gogo.runtime.CommandProxy.execute(CommandProxy.java:82)
	at org.apache.felix.gogo.runtime.Closure.executeCmd(Closure.java:477)
	at org.apache.felix.gogo.runtime.Closure.executeStatement(Closure.java:403)
	at org.apache.felix.gogo.runtime.Pipe.run(Pipe.java:108)
	at org.apache.felix.gogo.runtime.Closure.execute(Closure.java:183)
	at org.apache.felix.gogo.runtime.Closure.execute(Closure.java:120)
	at org.apache.felix.gogo.runtime.CommandSessionImpl.execute(CommandSessionImpl.java:89)
	at org.apache.felix.gogo.shell.Activator.run(Activator.java:75)
	at java.lang.Thread.run(Thread.java:701)
Caused by: java.lang.NoClassDefFoundError: org/thymeleaf/resourceresolver/IResourceResolver
	at java.lang.Class.getDeclaredConstructors0(Native Method)
	at java.lang.Class.privateGetDeclaredConstructors(Class.java:2545)
	at java.lang.Class.getConstructor0(Class.java:2845)
	at java.lang.Class.newInstance(Class.java:350)
	at org.apache.felix.framework.Felix.createBundleActivator(Felix.java:4362)
	at org.apache.felix.framework.Felix.activateBundle(Felix.java:2149)
	... 32 more
Caused by: java.lang.ClassNotFoundException: org.thymeleaf.resourceresolver.IResourceResolver not found by de.deepamehta.webactivator [18]
	at org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1556)
	at org.apache.felix.framework.BundleWiringImpl.access$400(BundleWiringImpl.java:77)
	at org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(BundleWiringImpl.java:1993)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
	... 38 more
java.lang.NoClassDefFoundError: org/thymeleaf/resourceresolver/IResourceResolver

Using the one built for http://download.deepamehta.de i have no trouble. Can you explain this strange behaviour?

Change History

comment:1 Changed 6 years ago by jri

In which directory did you build dm4-thymeleaf?
How did you deploy it?
What is the content of your bundle-deploy directory?
What does your bundle list (lb) look like?
Did you build DM from source?
Does the error persist?

The standard approach would be to build it in modules-external (in case DM is built from source) resp. bundle-dev (DM binary distro). It should be hot deployed then (by automatically being copied to bundle-deploy). Manual start via Gogo shell should not be required.

comment:2 Changed 6 years ago by jri

Once I recognized a similar error when having the same bundle deployed twice in Felix. Could this be the case?

Do you still have this error?

comment:3 Changed 5 years ago by jri

  • Status changed from new to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.