Ticket #969 (closed Enhancement: fixed)

Opened 4 years ago

Last modified 4 years ago

plugin development from deepamehta sources: enhancing capabilities of the modules-external dir

Reported by: Malte Owned by: jri
Priority: Trivial Milestone: Release 4.8.1
Component: DeepaMehta Standard Distribution Version: 4.7
Keywords: Cc:
Complexity: 1 Area: Application Framework / API
Module:

Description

When

  • having deepamehta-4.7 built from source and
  • droping a plugin binary into the "modules-external" i expect it to be at least attempted to be started

But this is not the case. When i drop a readymade ".jar" into the "modules-external" folder of my dm-4.7 source installation the framework does not attempt to activate it. This is useful as one might already have a prober binary version of a specific version build and bundled and just wants to install it, to be used with plugins currently in development. It frees one to enter paths into the pom.xml deploy.dir manually and checking out and building a specific version of a specific plugin (just for the sake of the other plugin actually in developmnent) again.

If this is the intended behaviour either the folder name is misleading me or the README is insufficient. In either case, dropping binaries into the "modules-external" folder is something we may want to support by default.

I worked around it through adding "modules-external" manually into my "felix.fileinstall.dir" property.

Change History

comment:1 Changed 4 years ago by jri

DM 4.7 has no modules-external directory. I guess you're talking about DM 4.8.

modules-external/about-this-directory.txt states:

This is where you develop your own DeepaMehta plugins.

Create a new directory here for each plugin.
Every time you build your plugin it gets automatically (re)deployed.

Use the modules-external directory when you've build DeepaMehta from source
and want develop 3rd-party plugins and DeepaMehta standard plugins in parallel.

So, this directory is for development your own plugins, not for deploying jars.

To manually deploy a jar drop it into bundle-deploy.

bundle-deploy is created (in the DM home directory) when you build DM for the first time.

In standard situations you don't need to enter any paths in pom.xml.

See #846

comment:2 Changed 4 years ago by Malte

  • Status changed from new to closed
  • Resolution set to fixed

I had the 4.8 once checked out but currently rebuilt the "4.7" from sources. Curiously the "modules-external" folder is still there (though it should have vanished after checking the 4.7). Maybe this is my fault because i created the folder manually, but i am not completely sure...

OK, thanks for the explanation - now i see there is also the "bundle-deploy" directory - Thanks for your help now i won't confuse the folders again.

Solution: Use the "bundle-deploy" directory to install bundles/jars (plugins).

Note: See TracTickets for help on using tickets.